Oppure

Loading
22/05/12 13:20
Brenza
Ciao a tutti, ho un router pirelli F226M di fastweb sbloccato tramite il payload di saxdax e vorrei configurare l'apparecchio per il WOL (wake on lan) il problema è che non riesco a fare il forwarding dei pacchetti udp sul broadcast...

dl.dropbox.com/u/12641440/Temp/…
dl.dropbox.com/u/12641440/Temp/…

Come potete vedere ho configurato tutto come spiegato in varie guide presenti sul web ma nulla da fare:
se spedisco il pacchetto dall'esterno della rete questo dovrebbe essere distribuito sull'intera lan cosa che invece non avviene
se spedisco il pacchetto da dentro la lan non ci sono problemi
se configuro il forwarding verso uno specifico ip della rete il pacchetto arriva (quindi tutto viaggia sulla porta giusta) ma se imposto 192.168.1.255 (indirizzo di broadcast) il pacchetto sembra perdersi per strada l'indirizzo penso sia giusto, l'ho calcolato da ip della rete 192.168.1.x e subnet mask 255.255.255.0


Soluzioni? Se qualcuno ha voglia di smanettare con router gli apro una porta per la gestione remota! =)
Ultima modifica effettuata da Brenza 22/05/12 13:27
aaa
23/05/12 23:22
nocturno
Ciao,
se il problema è legato solo all'assenza di ricezione del pacchetto di risposta da parte di tutti i dispositivi della rete (192.168.1.255) è perfettamente normale che non ci sia risposta; pensa se in una rete locale ci fossero 250 pc e tu invii in broadcast un pacchetto, come risposta al tuo pacchetto otterresti un flooding di 250 pacchetti di risposta tutti indirizzati al tuo pc, i quali inonderebbero il tuo computer rallentandone le prestazioni; il pacchetto di risposta non viene inviato di default all'IP di broadcast, ti parlo da programmatore di pacchetti di rete. ;)

Andrea
aaa
26/05/12 13:50
Brenza
Prima di tutto grazie per la risposta però non è questo il mio caso...
Mi sono spedito un magic packet da fuori della LAN mentre eseguivo WakeOnLanMonitor (depicus.com/wake-on-lan/…) su uno dei pc collegati al router via cavo ethernet, niente!

Se faccio il forwading del pacchetto verso l'ip del pc con cui monitorando ovviamente funziona ma il pc deve essere acceso, cosa inutile nel mio caso... se invece configuro il router per inviare il pacchetto all'indirizzo di broadcast sembra sparire nel nulla!



Ho anche provato ad aumentare il tempo in cui il router tiene associato un ip al mac address a 30 giorni per poter così inoltrare il pacchetto all'ip del computer ma a pc spento non arriva!
Ultima modifica effettuata da Brenza 26/05/12 13:52
aaa
08/06/12 15:57
Brenza
Nessuno??? :(
aaa
08/06/12 17:38
Brenza
EDIT: Scusate, doppio post! :(
Ultima modifica effettuata da Brenza 08/06/12 17:39
aaa